All indications are that our platform is operating normally now and all systems have recovered.
Posted Jun 12, 2025 - 14:50 PDT
Monitoring
GCP Services are back up and running. Our services are actively recovering, and we are closely monitoring their progress to ensure a full recovery.
Posted Jun 12, 2025 - 13:56 PDT
Update
We are continuing to investigate this issue.
Posted Jun 12, 2025 - 12:56 PDT
Update
This appears to be a global outage that is effecting multiple vendors and internet providers.
Posted Jun 12, 2025 - 12:55 PDT
Investigating
Google Cloud appears to be having a global outage, which is impacting our servers. We are investigating and will update once we have more information.
Posted Jun 12, 2025 - 11:21 PDT
This incident affected: API, Lytics Web Admin Portal, and Data Pipeline { ID Resolution, enrichment jobs, data import jobs and data export jobs, etc }.